You are Here:
Version Mismatch

Author (Read 474 times)

Version Mismatch
« on: October 25, 2021, 10:09:07 pm »
 

MelodyEmber

  • Newbie
  • *
  • 1
    Posts
  • Karma: 0
    • View Profile
I can't join any of the ice.org servers it says 'version mismatch' what's happening? I haven't been banned that I know of, I try to follow all rules.
 

Re: Version Mismatch
« Reply #1 on: October 26, 2021, 04:22:37 pm »
 

iSoSyS

  • Administrator
  • Jr. Member
  • *****
  • 69
    Posts
  • Karma: 5
    • View Profile
Hello MelodyEmber,
openttd recently released a new version 12.0. For the time being our servers are still running version 1.11.2. If you are using steam and it upgraded automatically you can try as a workaround change which version steam uses by going to game's properties, and within "Betas" tab select "1.11.2 - 1.11.2 release".